Mail Delivery Delays issues
Incident Report for ITS System Status
Resolved
Mail Delivery Delays issues have been resolved.
Posted Jan 12, 2017 - 14:02 EST
Update
Users may be experiencing delays in mail delivery caused by queuing related to high message volumes.
We will post updates as they become available.
Posted Jan 12, 2017 - 09:31 EST
Investigating
Users are currently experiencing delays in mail delivery caused by queuing related to high message volumes, as well as due to the storage issue this morning.
The issues will be resolved over time as queues are processed. No messages will be lost as a result of the issues.
Posted Jan 03, 2017 - 09:39 EST