Turnitin Service Alert
Incident Report for ITS System Status
Resolved
The Turnitin.com login issue with the website that occurred between 6:00AM - 10:29AM has been resolved.
We apologise for any inconvenience this may have caused.
Posted Sep 07, 2017 - 11:24 EDT
Investigating
Turnitin has reported that users may experience issues when logging in to the Turnitin.com website. They are actively investigating this. The Turnitin Integration in Portal courses does not appear to be affected. If you encounter issues with the Turnitin service please contact portal.help@utoronto.ca.
Posted Sep 07, 2017 - 09:12 EDT
This incident affected: Academic ToolBox (Ouriginal).