Turnitin Service Alert
Incident Report for ITS System Status
Resolved
Turnitin experienced a service degradation between 8:46AM - 9:36AM EST. The service is normal.
We apologise for any inconvenience which has been caused.
Posted May 16, 2017 - 11:48 EDT
Investigating
Turnitin users may experience degradation or slowness with the service this morning.
Turnitin is actively investigating these issues. We will provide updates as soon as they are available.
Posted May 16, 2017 - 09:49 EDT
This incident affected: Academic ToolBox (Ouriginal).