Turnitin Service Alert
Incident Report for ITS System Status
Resolved
Turnitin users experienced service degradation with accessing the Turnitin service today between 12:50PM - 2:30PM. Service has been restored.
We apologize for the inconvenience.
Posted Feb 16, 2018 - 18:03 EST
Investigating
Users may be experiencing slow Similarity Report generation or page errors when accessing the Originality Report itself. Turnitin is investigating the issue.
Posted Feb 16, 2018 - 14:42 EST
This incident affected: Academic ToolBox (Ouriginal).