Applicant Tracking System (Taleo) is not available
Incident Report for ITS System Status
Resolved
Taleo outage has been resolved, full service restored.
Posted Aug 11, 2017 - 13:32 EDT
Investigating
Please be advised that Taleo service is currently not available. Support staff are working on resolving the issue. Updates will be posted as they become available.
Posted Aug 11, 2017 - 13:15 EDT
This incident affected: Administrative Web Services (Applicant Tracking System (Taleo)).