UTM Network service interruption
Incident Report for ITS System Status
Resolved
UTM Network service interruption is now resolved
Posted Mar 16, 2017 - 12:53 EDT
Investigating
We are investigating a network service interruption at UTM campus. Support staff are actively working on resolving the issue. We will post updates as they become available.
Posted Mar 16, 2017 - 12:48 EDT