Email delay issues
Incident Report for ITS System Status
Resolved
The email delay issue has been resolved. Support staff are investigating the root cause and further information will be provided when available.
Posted Jun 27, 2017 - 13:46 EDT
Update
Longer than expected email delivery times are being reported for clients only on a single UTORmail server.
ITS is currently investigating the issue with high priority and will provide a resolution as soon as possible.
Posted Jun 27, 2017 - 09:08 EDT
Investigating
ITS Staff have received reports of users experiencing email delays and support staff are investigating.
Posted Jun 23, 2017 - 10:18 EDT
This incident affected: Email Systems (Listserv, UTMail+).