My Research & ESS Outage
Incident Report for ITS System Status
Resolved
My Research & ESS are now available
Posted Jun 12, 2017 - 16:15 EDT
Investigating
Please be advised that My Research (MR) & ESS are currently unavailable due to technical problem.
Our technical team is working on the problem.
Posted Jun 12, 2017 - 15:52 EDT
This incident affected: Administrative Web Services (ESS, My Research (MR)).