UTORExchange problem
Incident Report for ITS System Status
Resolved
Exchange Issue Resolved

With assistance from Microsoft, normal service has returned to our Exchange system this evening. Clients may continue to see a delay in receiving email as the system works to clear the queue. Again, thank you for your patience today.
Posted May 17, 2016 - 21:59 EDT
Update
We continue to encounter an issue with the UTORexchange service that is preventing access to approximately one third of our customers. We continue to work with our vendors to obtain a resolution on an urgent basis, however no estimate of when service will be fully restored is yet available. Please accept our apologies for the inconvenience.
Posted May 17, 2016 - 17:20 EDT
Investigating
Please note that ITS has received reports of some users having intermittent problems connecting to UTORExchange service. Support staff are currently investigating the issue.
Posted May 17, 2016 - 16:44 EDT