E-Mail Delivery Issues
Incident Report for ITS System Status
Resolved
This incident has been resolved.
Posted Jun 21, 2017 - 17:19 EDT
Monitoring
Wednesday Morning Update: Email delivery times were returning to normal overnight, however, ITS staff are continuing to monitor the situation and are continuing their efforts to analyze causes and plan for further potential mitigations should the University experience additional disruptions. Individual clients may experience an occasional delay in receiving some email that may have been stuck in a queue, but tests this morning show normal delivery times. Again, thank you for your patience over the past few days.
Posted Jun 21, 2017 - 08:01 EDT
Update
Tuesday Evening Update: ITS is aware of a large deluge of spam arriving in people's accounts at present. This is part of the ongoing problem and all available resources are being brought to bear on the problem. Thank you for your patience.
Posted Jun 20, 2017 - 17:57 EDT
Update
Tuesday Afternoon Update: ITS staff have received some queries about "other" systems not working, however, we have determined that the source of those concerns involves services which are dependent on email transactions. In other words, a service that is dependent on sending or receiving an email (for example, a password reset for some services), may not be responsive because the email may have been delayed.

ITS staff continue to work on mitigation strategies to improve the flow of email, but there is a large backlog, so delays may still be experienced. This is a top priority item.
Posted Jun 20, 2017 - 16:56 EDT
Update
Tuesday Mid-Day Update: ITS continue to add additional resources to the email environment to handle the increased load of inbound email, while continuing to investigate the cause of the increase. Customers may still be experiencing delays in receiving inbound email, especially from outside UofT. Internal messages sent via the Listserver may also be delayed. Thank you for your patience.
Posted Jun 20, 2017 - 13:40 EDT
Update
The University continues to experience difficulty with email delivery due to unusually high volumes of mail. Mail is being received, but there may be a delay (the time for delivery fluctuates between near instantaneous and several hours, and this affects both email from outside the University as well as internal email). ITS staff continue to investigate mitigations as a top priority. Thank you for your patience.
Posted Jun 20, 2017 - 09:47 EDT
Investigating
IT Staff have received reports of delayed e-mail arriving from sources external to the University. It appears to be due to an increased volume of email. IT staff are looking at ways of improving the flow.
Posted Jun 18, 2017 - 11:54 EDT