UTM Bell CENTREX voice telephone services interruption
Incident Report for ITS System Status
Resolved
UTM Bell CENTREX voice telephone services interruption has been resolved.
Posted Feb 16, 2017 - 16:11 EST
Investigating
The Bell CENTREX voice telephone services for approximately 400 customers at the University of Toronto at Mississauga are not available due to a cable cut. Bell Incident Management is working to resolve the issue.
Posted Feb 16, 2017 - 10:17 EST