UTORexchange Outbound Messages Placed in Drafts Folder
Incident Report for ITS System Status
Resolved
Please be advised that a potential fix has been applied and the UTORexchange Outbound Messages issue has been resolved.
After restarting Outlook, users are requested to report any new incidents of the issue to the Information Commons Help Desk at help.desk@utoronto.ca.
Posted Oct 26, 2016 - 15:48 EDT
Investigating
We are receiving reports of users that when they try to send a message, it gets delivered to their drafts folder instead of being sent. So far all reports have been from Mac users using Outlook 2016, however it’s not yet clear whether other platforms are also affected.

Investigation is underway. In the interim, messages can be opened from the drafts folder and sent as per normal.
Posted Oct 26, 2016 - 14:35 EDT