Voice mail outage at UTM
Incident Report for ITS System Status
Resolved
Voice mail at UTM is operational.
Posted Jul 13, 2017 - 09:24 EDT
Investigating
There is a voice mail system outage at UTM. Callers are not being routed to the recipients voice mail boxes.
Support staff are aware and working to resolve the issue.
Posted Jul 13, 2017 - 08:25 EDT