Home Use Program Unavailable
Incident Report for ITS System Status
Resolved
We have received our new HUP Code and have applied it to our tenant.
Posted May 15, 2017 - 09:47 EDT
Update
While we are not yet able to provide an ETA, the support team continues to work towards a full resolution.
Posted May 15, 2017 - 09:16 EDT
Identified
The Microsoft Home Use Program is unavailable during our annual renewal period. Our ability to issue new licenses should be restored in a few days.
Posted May 02, 2017 - 12:57 EDT
This incident affected: Client Support Services (Microsoft Campus Agreement).