UTORauth system issue
Incident Report for ITS System Status
Resolved
UTORauth system is now operational.
We apologize for the inconvenience and thank you for your patience.
Posted Jul 03, 2018 - 15:54 EDT
Investigating
UTORauth system is currently experiencing technical issues. We are working on restoring the services.
Posted Jul 03, 2018 - 15:37 EDT
This incident affected: Identity Management Systems (UTORauth-NET).