RRS Lite Room Booking System connection issues
Incident Report for ITS System Status
Resolved
RRS Lite Room Booking system is now operational.
Thank you for your patience.
Posted Jan 09, 2020 - 14:04 EST
Investigating
The University's RRS Lite Room Booking system is experiencing some connection issues.
Support staff at the Academic & Campus Events are working to restore service as soon as possible.
We will provide more updates as they become available.
Posted Jan 09, 2020 - 12:55 EST
This incident affected: Academic ToolBox (Other).