Edge DNS Service Incident
Incident Report for ITS System Status
Resolved
This incident has been mitigated.
Thank you for your patience.
Posted Jul 22, 2021 - 13:15 EDT
Investigating
Akamai Technical Support has reported that they are actively investigating an issue with the Edge DNS service.
We will provide more updates as they become available.
Posted Jul 22, 2021 - 12:56 EDT
This incident affected: Enterprise Networks (DNS).