uTime (Kronos) not available
Incident Report for ITS System Status
Resolved
Please note that the Kronos system is now open for business to U of T staff.
Thank you for your patience.
Posted Feb 07, 2022 - 08:24 EST
Identified
The Ultimate Kronos Group (UKG) team has completed restoration activities and the Kronos system will be open for business to U of T staff on Sunday, February 6, 2022 at 7:00 a.m.
Posted Feb 03, 2022 - 09:11 EST
Update
Ultimate Kronos Group (UKG) team are in regular communications with our technical team to complete the recovery activities. The Kronos system will be open for business to U of T staff on Sunday, February 6, 2022 at 7:00 a.m.

We will continue to receive updates from Kronos and will update the community on Thursday, February 3, 2022.
Posted Jan 25, 2022 - 10:18 EST
Update
The application continues to remain unavailable, and the Ultimate Kronos Group (UKG) is working to restore the service. The UKG team are in regular communications with our technical team with a target date of January 28 to fully restore service for the university.
Posted Jan 04, 2022 - 09:19 EST
Update
Kronos application continues to remain unavailable, and the issue is being investigated by the Ultimate Kronos Group (UKG). We will provide more updates as they become available.
Posted Dec 21, 2021 - 09:30 EST
Investigating
We have received reports of users not being able to access the uTime(Kronos) service.
We are aware of the problem and the issue is being investigated by the vendor.
Posted Dec 13, 2021 - 08:28 EST
This incident affected: Administrative Web Services (uTIME (Kronos)).