Individuals may be unable to access Microsoft Teams in UTMail+
Incident Report for ITS System Status
Resolved
Microsoft has corrected the problem. The Teams service is now fully operational.
Posted Feb 04, 2020 - 09:30 EST
Monitoring
Microsoft has reported that the Teams service has largely recovered and that they are monitoring for any residual impact.
Posted Feb 03, 2020 - 15:52 EST
Identified
Microsoft has identified the root cause for the outage and is currently applying a fix to address the problem.
Posted Feb 03, 2020 - 10:42 EST
Investigating
We have received reports of individuals having problems logging into or accessing Microsoft Teams in UTMail+ this morning. Microsoft is currently investigating.
Posted Feb 03, 2020 - 09:48 EST
This incident affected: Email Systems (Office 365).