Turnitin Degraded Performance
Incident Report for ITS System Status
Resolved
The issue with the evaluation viewer has been resolved.
We apologize for the inconvenience and thank you for your patience.
Posted Dec 07, 2018 - 15:44 EST
Investigating
The Turnitin Evaluation Viewer is currently experiencing degraded performance. The vendor is currently investigating the issue. Further updates will be provided as they become available. Please also see Turnitin's service status page at: https://turnitin.status.io/
Posted Dec 07, 2018 - 11:50 EST
This incident affected: Academic ToolBox (Ouriginal).