SSPR service unavailable
Incident Report for ITS System Status
Resolved
Self-Service Password Reset is now available.
We apologize for the inconvenience and thank you for your patience.
Posted Aug 04, 2020 - 09:39 EDT
Investigating
We has received reports of service interruption affecting Self Service Password Reset and It is currently being investigated.
Further updates will be provided as they become available.
Posted Aug 04, 2020 - 09:38 EDT
This incident affected: Identity Management Systems (Password Change / Reset / Secret Activation Key (SAK)).