Turnitin Service Alert
Incident Report for ITS System Status
Resolved
Slow submission/reporting times issue has been resolved.
We apologize for the inconvenience and thank you for your patience.
Posted Sep 17, 2018 - 16:05 EDT
Update
We are continuing to investigate this issue.
Posted Sep 17, 2018 - 16:03 EDT
Investigating
Users may experience slow submission/reporting times with Turnitin. The issue was reported at around 12:00AM last night. Turnitin is investigating.
Posted Sep 17, 2018 - 09:06 EDT
This incident affected: Academic ToolBox (Ouriginal).