MS Stream service issue
Incident Report for ITS System Status
Resolved
The issue has been resolved. Students can now view videos on the University’s Microsoft Stream Server.
Posted Aug 06, 2019 - 07:20 EDT
Investigating
We are currently experiencing an issue with the Microsoft Stream service; faculty and staff are able to upload videos at this time, however, students are not able to view them. Staff are investigating. Thank you for your patience
Posted Aug 02, 2019 - 13:15 EDT
This incident affected: Video-Mediated Communications (MS Stream).