Turnitin issue
Incident Report for ITS System Status
Resolved
The Turnitin issue has been resolved. Thank you for your patience.
Posted Jul 22, 2021 - 14:25 EDT
Investigating
Turnitin is experiencing an unexpected service degradation. During this time, you may find that Similarity Reports are not generating. The vendor is working to resolve this issue.
Posted Jul 22, 2021 - 10:44 EDT
This incident affected: Academic ToolBox (Ouriginal).