Investigating Reported Service Outages
Incident Report for ITS System Status
Resolved
Alibaba CEN service for Shanghai region is now operational.
We apologize for the inconvenience and thank you for your patience.
Posted Apr 05, 2021 - 10:01 EDT
Investigating
Please note that ITS has received reports of potential service interruption affecting the Shanghai region of the Alibaba CEN service. We are investigating the reports.

Updates will be posted as they become available.
Posted Apr 05, 2021 - 09:08 EDT