UTM Home page unavailable
Incident Report for ITS System Status
Resolved
UTM home page ervice has been restored.
Posted Apr 16, 2018 - 07:03 EDT
Identified
Due to a power outage at UTM, the UTM home page is currently unreachable.
Posted Apr 15, 2018 - 22:25 EDT
This incident affected: Web Services (UTM Home Page).