Quercus Outage
Incident Report for ITS System Status
Resolved
This incident has been resolved.
Posted Sep 21, 2022 - 14:46 EDT
Investigating
Quercus is currently experiencing a service outage. The service provider has been informed and is working to address the issue.
Posted Sep 21, 2022 - 14:26 EDT
This incident affected: Academic ToolBox (Quercus).