Faculty of Arts & Science home page unavailable
Incident Report for ITS System Status
Resolved
The Faculty of Arts & Science website is now available.
Thank you for your patience.
Posted Apr 17, 2019 - 14:56 EDT
Identified
The Faculty of Arts & Science website continues to experience an extended outage due to technical issues. A&S IIT support teams are investigating with urgency. Please contact iit@artsci.utoronto.ca if you have questions. Thank you for your patience as we work to resolve this issue.
Posted Apr 16, 2019 - 17:46 EDT
This incident affected: Web Services (Other).