Login issues affecting Degree Explorer, CIS, and Safety Abroad
Incident Report for ITS System Status
Resolved
The login problem has been resolved.
We apologize for the inconvenience and thank you for your patience.
Posted Apr 16, 2019 - 12:07 EDT
Investigating
Please note that the login problems to the following applications are recurring. We are investigating the issue and will provide more updates as they become available.

Degree Explorer (Student)
Degree Explorer (Admin)
Course Information System
Safety Abroad
Posted Apr 16, 2019 - 10:36 EDT
This incident affected: Student Web Services (Course Information System, Degree Explorer) and Administrative Web Services (Degree Explorer Admin).