Issue with Course Evaluations System
Incident Report for ITS System Status
Resolved
Issue with Course Evaluations System has been resolved.
Posted Jun 13, 2017 - 09:06 EDT
Investigating
Some instructors are currently reporting an issue viewing some of the academic admin/instructor reports in Blue (Course Evaluations System). Affected instructors may see a blank page instead of the report. ITS staff have opened a ticket with the vendor.
Posted Jun 12, 2017 - 11:19 EDT
This incident affected: Student Web Services (Course Evaluations).