ROSI & associated system slow response
Incident Report for ITS System Status
Resolved
ROSI, ACORN and other associated systems have now returned to normal.
We apologize for the inconvenience.
Posted Jan 04, 2017 - 08:18 EST
Identified
Due to the high volume of students accessing the site, ROSI, ACORN and other associated systems are expected to experience slow response times.
Posted Jan 03, 2017 - 15:58 EST