Unable to save attachments in Outlook Web App
Incident Report for ITS System Status
Resolved
Microsoft has confirmed that the fix has now completed deployment and they are monitoring telemetry to ensure the full recovery.

If users are still affected, make sure they log out and back into their devices for the changes to take effect.
Posted Apr 16, 2024 - 10:19 EDT
Update
Microsoft has completed the development of the fix and has begun the rollout and validation process.

Investigating
- Users may be intermittently unable to download attachments or view embedded images in Outlook on the web.
- Users may see the following error message when an attachment fails to download: “Error downloading the file content.”
- Users may also experience issues sending attachments.

While Microsoft is investigating the issue, potential workarounds are:
1. Try to Sign Out and Sign In to the Outlook Web App
2. Tyr to use the light version (https://outlook.office.com/owa/?layout=light) or the Outlook Desktop Client if available.
3. Switch to a different browser (Edge / Chrome)
4. Save files to the OneDrive from the attachment dropdown.

Some users may experience delays of up to five minutes accessing Outlook on the web and its features

Identified
Microsoft has developed and prepared to deploy a service optimization to alleviate impact immediately.
In parallel, they continue reviewing potential long-term restoration plans to fully resolve this issue.

Investigating
Some users whose requests are routed through the affected subset of infrastructure may see delays when accessing Exchange Online using Outlook.

Potential workarounds:
1. Open mail.utoronto.ca in the new Tab, Refresh the page with cleaning the cache:
hold CTRL and press F5 in Windows, hold CMD and Shift and press R on Mac.
2. Tyr to use Outlook Desktop Client if available.
Posted Apr 05, 2024 - 11:18 EDT
Identified
Microsoft has identified the problem and are working to resolve this issue.
Posted Apr 02, 2024 - 14:17 EDT
Investigating
The issue with downloading attachments from Outlook Web App (OWA) appears to be a common problem that may affect users across different browsers.

While Microsoft is investigating the issue, potential workarounds are:
1. Try using the OWA light version (https://outlook.office.com/owa/?layout=light),
2. Switch to a different browser (Edge / Chrome)
3. Save files to the OneDrive from the attachment dropdown.
Posted Apr 02, 2024 - 11:11 EDT
This incident affected: Email Systems (Office 365).