adminVPN issue
Incident Report for ITS System Status
Resolved
The adminVPN issue has been resolved. Thank you for your patience.
Posted Mar 20, 2024 - 16:18 EDT
Investigating
We have received reports of AdminVPN connection issues. Information Security is investigating and will provide updates as they come available,
Posted Mar 20, 2024 - 15:38 EDT
This incident affected: VPN Services (Admin Systems VPN).