UTORexchange Login Issues
Incident Report for ITS System Status
Resolved
UTORexchange Login Issue has been resolved.
Posted Oct 14, 2016 - 12:48 EDT
Investigating
We are receiving reports of some users having issues connecting to UTORexchange. Staff are actively working to respond to the issue and a resolution is expected very shortly.
Posted Oct 14, 2016 - 12:27 EDT