Convocation e-ticketing
Incident Report for ITS System Status
Resolved
Convocation e-ticketing issue has been resolved.
Posted May 20, 2016 - 10:08 EDT
Investigating
If you are eligible to graduate in June 2016 please be advised that the download and confirmation of guest tickets function is currently not working. We are looking into the problem and hope to have it resolved shortly.
Posted May 20, 2016 - 09:36 EDT