Degraded Internet Service
Incident Report for ITS System Status
Resolved
19:30 The ISP has repaired the damaged fibre.
Posted Mar 21, 2024 - 20:58 EDT
Identified
One of the ISP connections on ORION failed. The ISP has assigned the fibre teams working on multiple locations to restore the service. We are monitoring the situation closely and will provide an update once it becomes available.
Posted Mar 21, 2024 - 17:13 EDT
This incident affected: Enterprise Networks (Campus Backbone Network).