Slow Internet Connection Issue
Incident Report for ITS System Status
Resolved
The slow/intermittent internet connection issue has been resolved.
Thank you for your patience during this service interruption.
Posted Feb 14, 2017 - 10:23 EST
Update
The slow/intermittent internet connection issue has been resolved.
Thank you for your patience during this service interruption.
Posted Feb 14, 2017 - 10:11 EST
Investigating
We are investigating reported issues with slow or intermittent Internet connection.
Support teams are aware of the issues and are working towards resolution.
Posted Feb 14, 2017 - 09:36 EST