Reports of some delays in sending messages from UTMail+
Incident Report for ITS System Status
Resolved
This incident has been resolved.
Posted Apr 18, 2024 - 09:50 EDT
Monitoring
Microsoft implemented a fix for this issue and they believe that they have fully restored mail flow. Please contact your local helpdesk if you continue to experience issues sending mail from your UTMail+ account.
Posted Apr 17, 2024 - 16:06 EDT
Update
Microsoft has identified portions of their mail flow infrastructure that are performing below service performance thresholds and are continuing to work toward identifying the source of the problem.
Posted Apr 17, 2024 - 13:56 EDT
Update
Microsoft has acknowledged this issue and is currently investigating.
Posted Apr 17, 2024 - 11:35 EDT
Investigating
We have received reports of some delays in sending email messages from UTMail+ We are currently investigating this issue.
Posted Apr 17, 2024 - 11:24 EDT
This incident affected: Email Systems (UTMail+).