Communicator 7 Login Issue
Incident Report for ITS System Status
Resolved
The issue with VoIP softphone client Communicator 7 has been resolved.
We apologize for any inconvenience caused.
Posted Jun 24, 2020 - 19:25 EDT
Investigating
We are currently experiencing an issue with VoIP softphone client Communicator 7, when users try to sign in, they receive a message saying “Connection to Server failed, please try again later. If the problem persists please contact your service provider”

We have engaged with the provider on this issue, they are investigating this issue with high priority.
Posted Jun 24, 2020 - 16:36 EDT
This incident affected: Telecommunications (GoCo/BroadConnect VoIP – Polycom Devices).