Quercus access issue
Incident Report for ITS System Status
Resolved
Quercus access issue has been resolved.
We apologize for the inconvenience and thank you for your patience.
Posted Oct 14, 2020 - 10:06 EDT
Investigating
We have received reports from users experiencing Quercus access issues. It is currently being investigated and hope to resolve it as soon as possible. Further updates will be provided as they become available.
Thank you for your patience and we apologise for the inconvenience caused.
Posted Oct 14, 2020 - 08:09 EDT
This incident affected: Academic ToolBox (Quercus).