Partial Service Disruption - OneDrive and SharePoint

Incident Report for ITS System

Resolved

Comment from Lisa (SharePoint Admin) : For now, only three users have mentioned the issue, so I don’t think it’s as wide-spread as initially believed.
Posted Jun 25, 2026 - 12:00 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 22, 2026 - 12:12 EDT

Investigating

A subset of features within OneDrive and SharePoint are currently unavailable. When sharing internally and externally, Share links aren't functioning as expected in SharePoint and OneDrive and users can't access files and folders shared to them. This is happening across our tenant and Microsoft is investigating this issue.
Posted Jun 19, 2026 - 10:03 EDT
This incident affected: Email Systems (Microsoft 365).