Microsoft reports that the service issue affecting the triggering, viewing, and management of Power Automate flows has been resolved. If you are still experiencing an impact, please submit a ticket using uoft.me/esc
Posted Aug 20, 2026 - 13:46 EDT
Monitoring
Microsoft reports that the service issue affecting the triggering, viewing, and management of Power Automate flows has been resolved. Microsoft increased service capacity and rebalanced load across the affected infrastructure. We are continuing to monitor the U of T tenant for any ongoing or recurring impact. Further updates will be provided if necessary.
Posted Aug 20, 2026 - 13:13 EDT
Identified
Microsoft has identified an issue affecting infrastructure supporting Power Automate, resulting in intermittent failures when users view or manage flows. Microsoft has completed a failover of the affected services and is monitoring for recovery. We will provide further updates as they become available.
Posted Aug 20, 2026 - 11:55 EDT
Investigating
Some users are experiencing connectivity issues with Power Platform services. We are actively investigating the issue and will share additional updates as soon as more information is available.
Posted Aug 20, 2026 - 10:27 EDT
This incident affected: Email Systems (Microsoft 365).