Turnitin issue affecting Quercus integration
Incident Report for ITS System Status
Resolved
The Turnitin issue affecting Quercus integration has now been resolved.
Thank you for your patience.
Posted Feb 01, 2021 - 09:44 EST
Investigating
An issue has been identified affecting the generation of Turnitin similarity scores for assignments submitted through Quercus. Turnitin is actively working to resolve the problem.
Posted Jan 29, 2021 - 17:00 EST
This incident affected: Academic ToolBox (Ouriginal).