Exchange Online (Outlook) - Service Degradation

Incident Report for ITS System

Resolved

Microsoft’s fix is fully deployed across affected environments. Availability has returned to expected thresholds. They are monitoring service health telemetry to confirm full remediation.
Posted Oct 07, 2025 - 10:24 EDT

Update

Microsoft reports the fix is 99.5% deployed across affected environments. Once it reaches 100%, they will monitor service telemetry to confirm resolution.
Posted Oct 06, 2025 - 09:36 EDT

Monitoring

Microsoft’s networking fix has fully deployed. They have begun deploying the subsequent fix to optimize the affected infrastructure and remediate impact. A completion timeline will be shared once available.
Posted Oct 03, 2025 - 10:07 EDT

Update

Microsoft has completed validation of the networking fix and started deployment. Completion is expected by the next scheduled update (Thursday, October 2, 2025 at 4:00 PM EDT). After that, Microsoft will initiate the subsequent service-side fix across the impacted infrastructure.
Posted Oct 02, 2025 - 09:30 EDT

Identified

Impact: Some users cannot access Exchange Online mailboxes or send email.
Affected methods: Outlook on the web, Outlook desktop, Messaging API, REST API, Exchange ActiveSync.
Symptoms: OWA send may hang 10+ minutes; intermittent access failures; some see “Something went wrong.”

Current status:
Related to prior incident EX1158764. Microsoft confirmed the impact stems from a service-side cleanup operation that is failing to complete. A fix was developed and released, but an unrelated networking issue prevented acceptance on all affected machines. Microsoft is resolving the networking issue, will re-initiate the fix, and will share a remediation timeline once available.
Posted Oct 01, 2025 - 14:12 EDT
This incident affected: Email Systems (UTMail+).