Turnitin service disruption
Incident Report for ITS System Status
Resolved
The issue has now been resolved.
We apologize for the inconvenience and thank you for your patience.
Posted Mar 02, 2021 - 10:34 EST
Investigating
Integrations users unable to submit or view Similarity Reports - SimCheck, Similarity & Originality are currently experiencing an unexpected service disruption.
Posted Mar 01, 2021 - 12:26 EST
This incident affected: Academic ToolBox (Ouriginal).