Problems accessing UTMail+ via https://mail.utoronto.ca and Alumni Mail via https://alumnimail.utoronto.ca

Incident Report for ITS System

Resolved

Microsoft has successfully reverted the code change and the problem has been corrected.
Posted Sep 18, 2026 - 16:46 EDT

Update

Microsoft has indicated that their code reversion is taking longer than originally expected. It is currently 82% complete and is expected to fully complete by tomorrow (Friday) at 5pm.
Posted Sep 17, 2026 - 16:56 EDT

Update

Microsoft rolled back the code change but it did not appear to correct the issue. We are continuing to work with them towards a resolution.
Posted Sep 17, 2026 - 09:24 EDT

Identified

Microsoft has determined that this problem was the result of a code change within Exchange Online. They are in the process of reversing the change and will provide an update at 5pm.
Posted Sep 16, 2026 - 15:36 EDT

Update

There appears to be a problem with Microsoft's home realm discovery/redirect service - we have engaged them to troubleshoot. In the meantime, please use https://outlook.office.com to access UTMail+ or the Alumni Email service on the web.
Posted Sep 16, 2026 - 14:08 EDT

Investigating

We have received reports of problems accessing UTMail+ and Alumni Mail using https://mail.utoronto.ca and https://alumnimail.utoronto.ca, respectively. We are currently investigating.
Posted Sep 16, 2026 - 13:50 EDT
This incident affected: Email Systems (UTMail+).