Issues accessing Alumni Tenant using Outlook

Incident Report for ITS System Status

Resolved

This incident has been resolved.
Posted May 15, 2025 - 13:14 EDT

Monitoring

Microsoft has confirmed that a recent service update is the root cause for this issue. We have implemented a Microsoft suggested workaround to temporarily address the issue but Microsoft has cautioned that this issue may return as they work to remove the offending service update.

We will continue to monitor.
Posted May 13, 2025 - 13:47 EDT

Identified

Microsoft believes that a recent change that they have made to the service is the root cause of this issue.
Posted May 13, 2025 - 09:58 EDT

Investigating

We are currently investigating reports that individuals are unable to access their Alumni email mailbox using Outlook for Windows/Mac and via mobile devices. Individuals can still access their mailbox using the web interface (https://www.office.com/)
Posted May 13, 2025 - 09:37 EDT
This incident affected: Email Systems (Other).