Sectigo cert-manager.com experiencing major disruptions
Incident Report for ITS System Status
Resolved
Sectigo reports that cert-manager.com is operational again.
Apologize for the inconvenience caused.
Posted Jun 16, 2020 - 07:07 EDT
Update
Sectigo reports that services is available with degraded performance.
Posted Jun 15, 2020 - 16:40 EDT
Investigating
Our SSL certificate service with Sectigo runs via the website cert-manager.com. The University uses this site to submit and approve SSL certificates. The site is currently experiencing major disruptions. We are awaiting status reports. Though it prevents us from issuing new certificates, this does not affect existing ones.
Posted Jun 15, 2020 - 10:51 EDT
This incident affected: Information Security (Other).