Exchange Online Service degradation
Incident Report for ITS System Status
Resolved
This incident has been resolved.
We apologize for the inconvenience and thank you for your patience.
Posted Sep 30, 2022 - 09:41 EDT
Update
We've received some reports that removing and re-adding the shared calendar for affected users may work as a temporary solution.
Thank you for your patience.
Posted Sep 28, 2022 - 13:41 EDT
Investigating
Some users' and delegates' shared calendars may not sync new events in Exchange Online through any connection method. Support staff are working on resolving the issue. We will provide more updates as they become available.
Posted Sep 27, 2022 - 16:13 EDT
This incident affected: Email Systems (Other).