Edge firewall degraded state

Incident Report for ITS System

Update

We are continuing to work on a fix for this issue.
Posted Jun 01, 2026 - 11:17 EDT

Update

We are continuing to troubleshoot the firewall issues. Further testing may need to be performed; we will post updates here before performing any operations that could cause network interruptions.
Posted Jun 01, 2026 - 11:16 EDT

Identified

We have reverted our previous fix and revised our diagnosis, network connectivity should be restored to normal.
Posted May 29, 2026 - 14:39 EDT

Update

We are continuing to investigate reports of intermittent connectivity across campus networks.
Posted May 29, 2026 - 12:45 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 29, 2026 - 11:16 EDT

Investigating

We are currently investigating an issue stemming from maintenance of the edge firewall CHG32398. Campus connectivity is not affected and all firewall protections remain in place. Details are being tracked in INC1867478.
Posted May 28, 2026 - 23:42 EDT
This incident affects: Information Security (Firewall Services).